Cookies are blocked or not supported by your browser. You must enable cookies in your browser settings to use proxyvote.com.
English | Français

ALERT: In order to use ProxyVote, you will need to upgrade and/or make the appropriate configuration changes to your browser as described below.

As part of our on-going commitment to information security on the web, ProxyVote has switched from Secure Socket Layer (SSLv3) protocol to the new industry standard Transport Layer Security (TLS).

Users of ProxyVote will be affected if their browser still relies on SSL-Level security, after September 30, 2015.

In order to enable TLS for Internet Explorer (IE) 8 or 9, please take the following action:

Users of ProxyVote that are using browsers other than Internet Explorer should refer to the recommended upgrade path of their particular browser’s support website.

While we strongly suggest you upgrade your browser now so you can vote, if you choose not to upgrade at this time, you can still vote using the alternative methods outlined in the material you have received.